aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel <kingdread@gmx.de>2020-04-06 14:43:28 +0200
committerDaniel <kingdread@gmx.de>2020-04-06 14:43:28 +0200
commita304370df4f998f7054731bac173113f91bf5cb1 (patch)
treeaab806f530e8871dbc35368e021485dc02265c54 /Cargo.toml
parentf7a0f17ce47e15f4cb39b49fecf4e252ce7897c3 (diff)
downloadraidgrep-a304370df4f998f7054731bac173113f91bf5cb1.tar.gz
raidgrep-a304370df4f998f7054731bac173113f91bf5cb1.tar.bz2
raidgrep-a304370df4f998f7054731bac173113f91bf5cb1.zip
implement guild display & filtering options
Filtering based on guilds is slow, as it will have to retrieve every guild name from the GW2 API, and it has to parse every log file instead of bailing early. Therefore, guilds are not searched by default, and have to be explicitely turned on with --guilds. In addition, this means that raidgrep will now need network access when --guilds is passed, which was not the case before.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index efb4fdb..85b7792 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,3 +17,8 @@ num-traits = "0.2"
humantime = "2.0"
zip = "0.5"
anyhow = "1.0"
+once_cell = "1.3"
+ureq = { version = "0.12", features = ["json"] }
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+dirs = "2.0"