aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel <kingdread@gmx.de>2020-04-21 14:34:08 +0200
committerDaniel <kingdread@gmx.de>2020-04-21 14:34:08 +0200
commitab909d2f3a0a59ae1b9a169ec79d4e9ffeddd1e1 (patch)
tree37d5360b3ca2056609bbad3497103b1437b25107 /Cargo.toml
parent0a27adbc0bf3bbbf87fea9e55c00c38f61d55058 (diff)
downloadraidgrep-ab909d2f3a0a59ae1b9a169ec79d4e9ffeddd1e1.tar.gz
raidgrep-ab909d2f3a0a59ae1b9a169ec79d4e9ffeddd1e1.tar.bz2
raidgrep-ab909d2f3a0a59ae1b9a169ec79d4e9ffeddd1e1.zip
use readline/rustyline instead of stdin.read_line
This gives us a history, nicer editing capabilities and the possibility to add completion in the future.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2d64d51..2825776 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -26,6 +26,7 @@ dirs = "2.0"
log = { version = "0.4", features = ["std"] }
thiserror = "1.0"
lalrpop-util = "0.18"
+rustyline = "6.1"
[build-dependencies]
lalrpop = { version = "0.18", features = ["lexer"] }