aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/pyproject.toml b/pyproject.toml
index c419726..40cdc06 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -25,7 +25,7 @@ repository = "https://gitlab.com/dunj3/fietsboek"
keywords = ["web", "gpx"]
[tool.poetry.dependencies]
-python = "^3.9"
+python = "^3.10"
pyramid = "^2"
pyramid_jinja2 = "^2.10"
@@ -36,12 +36,12 @@ waitress = "^3"
SQLAlchemy = { version = "^2.0.15", extras = ["mypy"] }
alembic = "^1.8"
-transaction = "^4"
+transaction = "^5"
"zope.sqlalchemy" = "^3.0"
redis = "^5"
Babel = "^2.11"
-cryptography = "^42"
+cryptography = "^43"
gpxpy = "^1.5"
markdown = "^3.4"
nh3 = "^0.2.9"
@@ -59,8 +59,8 @@ fitparse = "^1.2.0"
optional = true
[tool.poetry.group.docs.dependencies]
-Sphinx = "^7.0"
-sphinx-autodoc-typehints = "^1.19.5"
+Sphinx = "^8.0"
+sphinx-autodoc-typehints = "^2.5"
[tool.poetry.group.testing]
optional = true
@@ -68,8 +68,8 @@ optional = true
[tool.poetry.group.testing.dependencies]
pytest = "^8.0.0"
webtest = "^3.0.0"
-pytest-cov = "^5.0.0"
-pytest-playwright = "^0.4.0"
+pytest-cov = "^6.0.0"
+pytest-playwright = "^0.6.0"
[tool.poetry.group.linters]
optional = true