aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Schadt <kingdread@gmx.de>2022-11-15 20:08:04 +0100
committerDaniel Schadt <kingdread@gmx.de>2022-11-15 20:08:04 +0100
commit3eb21aaf91e9201c54f0cfe5b16b99f5975bf698 (patch)
tree1f7c61f29c8bfb824faf6883f49bf1499fd0b248 /setup.py
parentfda3366cb319fa0c7d59d5d2bd873e39b8482a1d (diff)
downloadfietsboek-3eb21aaf91e9201c54f0cfe5b16b99f5975bf698.tar.gz
fietsboek-3eb21aaf91e9201c54f0cfe5b16b99f5975bf698.tar.bz2
fietsboek-3eb21aaf91e9201c54f0cfe5b16b99f5975bf698.zip
switch out setuptools for poetry
setup.py is the very old style for packaging, so I wanted to replace it with something more "modern". pyproject.toml seems like the way to go in the future. At first, I wanted to simply configure setuptools using pyproject.toml, but that support is in beta and seemed to cause some issues with the tox virtualenvs. Poetry seems to work fine and provides a better dependency resolver (given that dependencies are actually specified well) and some other goodies. For users, nothing much should change, as "pip install" still works.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py69
1 files changed, 0 insertions, 69 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100644
index 5fd76e0..0000000
--- a/setup.py
+++ /dev/null
@@ -1,69 +0,0 @@
-import os
-
-from setuptools import setup, find_packages
-
-here = os.path.abspath(os.path.dirname(__file__))
-with open(os.path.join(here, 'README.md')) as f:
- README = f.read()
-with open(os.path.join(here, 'CHANGELOG.rst')) as f:
- CHANGES = f.read()
-
-requires = [
- 'plaster_pastedeploy',
- 'pyramid',
- 'pyramid_jinja2',
- 'pyramid_debugtoolbar',
- 'waitress',
- 'alembic',
- 'pyramid_retry',
- 'pyramid_tm',
- 'SQLAlchemy',
- 'transaction',
- 'zope.sqlalchemy',
- 'importlib_resources',
- 'Babel',
- 'cryptography',
- 'gpxpy',
- 'markdown',
- 'bleach',
- 'Click',
-]
-
-tests_require = [
- 'WebTest',
- 'pytest',
- 'pytest-cov',
-]
-
-setup(
- name='fietsboek',
- version='0.3.0',
- description='fietsboek',
- long_description=README + '\n\n' + CHANGES,
- classifiers=[
- 'Programming Language :: Python',
- 'Framework :: Pyramid',
- 'Topic :: Internet :: WWW/HTTP',
- 'Topic :: Internet :: WWW/HTTP :: WSGI :: Application',
- ],
- author='',
- author_email='',
- url='',
- keywords='web pyramid pylons',
- packages=find_packages(exclude=['tests']),
- include_package_data=True,
- zip_safe=False,
- extras_require={
- 'testing': tests_require,
- },
- install_requires=requires,
- entry_points={
- 'paste.app_factory': [
- 'main = fietsboek:main',
- ],
- 'console_scripts': [
- 'fietsctl=fietsboek.scripts.fietsctl:main',
- 'fietsupdate=fietsboek.updater.cli:cli',
- ],
- },
-)