diff options
author | Daniel <kingdread@gmx.de> | 2020-05-03 12:18:01 +0200 |
---|---|---|
committer | Daniel <kingdread@gmx.de> | 2020-05-03 12:18:01 +0200 |
commit | 9fa6558e71a86e5a58445f1967025ac3511abe86 (patch) | |
tree | 8ab3e0837d433148b78adfa6280475834b20a162 /Cargo.toml | |
parent | db1f38ca7c1b269ee08c2d56788dafc154cffb5b (diff) | |
download | raidgrep-9fa6558e71a86e5a58445f1967025ac3511abe86.tar.gz raidgrep-9fa6558e71a86e5a58445f1967025ac3511abe86.tar.bz2 raidgrep-9fa6558e71a86e5a58445f1967025ac3511abe86.zip |
evtclib: include as a dependency, not submodule
With evtclib being on crates.io now (and generally, being available
publicly through git), there is no longer a need to have a copy of the
evtclib repository in this repository. The main reason was that evtclib
was private when I started it, so the easiest way to include it was
through a git submodule. That reason is no longer valid.
If we really *need* to use the git version, it is also better to just
point Cargo to the repository and let it deal with keeping the
repository up-to-date, rather than using git submodules.
This commit also updates Cargo.lock, so there is a bit of noise from
also adding ctrlc as a dependency.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -12,7 +12,7 @@ repository = "https://gitlab.com/dunj3/raidgrep" lto = true [dependencies] -evtclib = { path = "evtclib" } +evtclib = "0.3.0" regex = "1" structopt = "0.3" walkdir = "2" |