aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml21
1 files changed, 8 insertions, 13 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 158273a..dd64e8f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,30 +1,25 @@
[package]
-name = "modderbaas"
+name = "modderbaas-cli"
version = "0.1.0"
authors = ["Daniel Schadt <kingdread@gmx.de>"]
edition = "2018"
+[[bin]]
+name = "modderbaas"
+path = "src/main.rs"
+
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[workspace]
+
[dependencies]
anyhow = "1.0.45"
clap = "2.33.3"
-dirs = "4.0.0"
itertools = "0.10.1"
log = "0.4.14"
-once_cell = "1.8.0"
-regex = "1.5.4"
-scraper = "0.12.0"
-serde = { version = "1.0.130", features = ["derive"] }
+modderbaas = { path = "modderbaas" }
stderrlog = "0.5.1"
-tempdir = "0.3.7"
termcolor = "1.1.2"
-thiserror = "1.0.30"
-toml = "0.5.8"
-ureq = { version = "2.3.0", features = ["json"] }
-url = { version = "2.2.2", features = ["serde"] }
-uuid = { version = "0.8.2", features = ["v4"] }
-zip = "0.5.13"
[target.'cfg(unix)'.dependencies]
nix = "0.23.0"