aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py69
1 files changed, 0 insertions, 69 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100644
index 5fd76e0..0000000
--- a/setup.py
+++ /dev/null
@@ -1,69 +0,0 @@
-import os
-
-from setuptools import setup, find_packages
-
-here = os.path.abspath(os.path.dirname(__file__))
-with open(os.path.join(here, 'README.md')) as f:
- README = f.read()
-with open(os.path.join(here, 'CHANGELOG.rst')) as f:
- CHANGES = f.read()
-
-requires = [
- 'plaster_pastedeploy',
- 'pyramid',
- 'pyramid_jinja2',
- 'pyramid_debugtoolbar',
- 'waitress',
- 'alembic',
- 'pyramid_retry',
- 'pyramid_tm',
- 'SQLAlchemy',
- 'transaction',
- 'zope.sqlalchemy',
- 'importlib_resources',
- 'Babel',
- 'cryptography',
- 'gpxpy',
- 'markdown',
- 'bleach',
- 'Click',
-]
-
-tests_require = [
- 'WebTest',
- 'pytest',
- 'pytest-cov',
-]
-
-setup(
- name='fietsboek',
- version='0.3.0',
- description='fietsboek',
- long_description=README + '\n\n' + CHANGES,
- classifiers=[
- 'Programming Language :: Python',
- 'Framework :: Pyramid',
- 'Topic :: Internet :: WWW/HTTP',
- 'Topic :: Internet :: WWW/HTTP :: WSGI :: Application',
- ],
- author='',
- author_email='',
- url='',
- keywords='web pyramid pylons',
- packages=find_packages(exclude=['tests']),
- include_package_data=True,
- zip_safe=False,
- extras_require={
- 'testing': tests_require,
- },
- install_requires=requires,
- entry_points={
- 'paste.app_factory': [
- 'main = fietsboek:main',
- ],
- 'console_scripts': [
- 'fietsctl=fietsboek.scripts.fietsctl:main',
- 'fietsupdate=fietsboek.updater.cli:cli',
- ],
- },
-)