aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e6dcf34..9101fb0 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -37,14 +37,14 @@ waitress = "^2.1"
SQLAlchemy = "^1.4"
alembic = "^1.8"
transaction = "^3"
-"zope.sqlalchemy" = "^1.6"
+"zope.sqlalchemy" = "^2.0"
redis = "^4.3.4"
Babel = "^2.11"
cryptography = "^39"
gpxpy = "^1.5"
markdown = "^3.4"
-bleach = "^5"
+bleach = "^6"
Click = "^8.1"
requests = "^2.28.1"
@@ -57,7 +57,7 @@ brotli = "^1.0.9"
optional = true
[tool.poetry.group.docs.dependencies]
-Sphinx = "^5.3"
+Sphinx = "^6.1"
sphinx-autodoc-typehints = "^1.19.5"
[tool.poetry.group.testing]
@@ -74,16 +74,16 @@ optional = true
[tool.poetry.group.linters.dependencies]
pylint = "^2.15.8"
-black = "^22.12.0"
+black = "^23.1.0"
[tool.poetry.group.types]
optional = true
[tool.poetry.group.types.dependencies]
-mypy = "^0.991"
+mypy = "^1.1"
types-markdown = "^3.4.2.1"
types-requests = "^2.28.11.5"
-types-bleach = "^5.0.3.1"
+types-bleach = "^6"
types-babel = "^2.11.0.7"
types-redis = "^4.3.21.6"