aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 32d5595..618b2d5 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -38,7 +38,7 @@ SQLAlchemy = { version = "^2.0.15", extras = ["mypy"] }
alembic = "^1.8"
transaction = "^3"
"zope.sqlalchemy" = "^3.0"
-redis = "^4.3.4"
+redis = "^5"
Babel = "^2.11"
cryptography = "^41.0.1"
@@ -48,7 +48,7 @@ nh3 = "^0.2.9"
Click = "^8.1"
requests = "^2.28.1"
-pydantic = "^1.10.2"
+pydantic = "^2"
termcolor = "^2.1.1"
filelock = "^3.8.2"
brotli = "^1.0.9"
@@ -69,13 +69,13 @@ optional = true
pytest = "^7.2.0"
webtest = "^3.0.0"
pytest-cov = "^4.0.0"
-pytest-playwright = "^0.3.0"
+pytest-playwright = "^0.4.0"
[tool.poetry.group.linters]
optional = true
[tool.poetry.group.linters.dependencies]
-pylint = "^2.15.8"
+pylint = "^3"
black = "^23.1.0"
[tool.poetry.group.types]