aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f3918b6..1c48b02 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -32,7 +32,7 @@ pyramid_jinja2 = "^2.10"
pyramid_debugtoolbar = "^4.9"
pyramid_retry = "^2.1"
pyramid_tm = "^2.5"
-waitress = "^2.1"
+waitress = "^3"
SQLAlchemy = { version = "^2.0.15", extras = ["mypy"] }
alembic = "^1.8"
@@ -41,7 +41,7 @@ transaction = "^4"
redis = "^5"
Babel = "^2.11"
-cryptography = "^41.0.1"
+cryptography = "^42"
gpxpy = "^1.5"
markdown = "^3.4"
nh3 = "^0.2.9"
@@ -66,9 +66,9 @@ sphinx-autodoc-typehints = "^1.19.5"
optional = true
[tool.poetry.group.testing.dependencies]
-pytest = "^7.2.0"
+pytest = "^8.0.0"
webtest = "^3.0.0"
-pytest-cov = "^4.0.0"
+pytest-cov = "^5.0.0"
pytest-playwright = "^0.4.0"
[tool.poetry.group.linters]
@@ -76,7 +76,7 @@ optional = true
[tool.poetry.group.linters.dependencies]
pylint = "^3"
-black = "^23.1.0"
+black = "^24.0.0"
[tool.poetry.group.types]
optional = true