aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Schadt <kingdread@gmx.de>2022-12-05 21:06:25 +0100
committerDaniel Schadt <kingdread@gmx.de>2022-12-05 21:06:25 +0100
commitd1f07803e39c1072127315821580eea3939fb51f (patch)
tree8c33f5093dde0cacfab79393ab1be523060813aa /pyproject.toml
parenta95a9768135bcaaa856a7cca98409a49250c96fa (diff)
downloadfietsboek-d1f07803e39c1072127315821580eea3939fb51f.tar.gz
fietsboek-d1f07803e39c1072127315821580eea3939fb51f.tar.bz2
fietsboek-d1f07803e39c1072127315821580eea3939fb51f.zip
parse/validate config with pydantic
This is the first step, in the next step, we should actually use request.config.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 1f87521..42f8ea3 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -54,6 +54,8 @@ requests = "^2.28.1"
WebTest = {version = "^3", optional = true}
pytest = {version = "^7.2", optional = true}
pytest-cov = {version = "*", optional = true}
+pydantic = "^1.10.2"
+termcolor = "^2.1.1"
[tool.poetry.group.docs]
optional = true