diff options
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 7 |
1 files changed, 5 insertions, 2 deletions
@@ -8,7 +8,7 @@ license = "MIT" # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html [features] -im-matrix = ["matrix-sdk", "tokio"] +im-matrix = ["matrix-sdk", "tokio", "serde_json", "rand", "dirs"] im-discord = ["serenity", "tokio"] [dependencies] @@ -28,7 +28,10 @@ toml = "0.5.8" itertools = "0.10.3" # Optional features for IM integration tokio = { version = "1.17.0", features = ["rt"], optional = true } -matrix-sdk = { version = "0.4.1", optional = true } +matrix-sdk = { version = "0.7.1", optional = true } +serde_json = { version = "1.0.91", optional = true } +rand = { version = "0.8.5", optional = true } +dirs = { version = "5.0.1", optional = true } [dependencies.serenity] default-features = false |