aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml33
1 files changed, 16 insertions, 17 deletions
diff --git a/Cargo.toml b/Cargo.toml
index be81e30..9b1b626 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,28 +8,27 @@ license = "MIT"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[features]
-im-matrix = ["matrix-sdk", "ruma", "tokio"]
+im-matrix = ["matrix-sdk", "tokio"]
im-discord = ["serenity", "tokio"]
[dependencies]
-clap = { version = "3.1.6", features = ["derive"] }
-log = "0.4.8"
+clap = { version = "3.1.8", features = ["derive"] }
+log = "0.4.16"
pretty_env_logger = "0.4.0"
-anyhow = "1.0.31"
-evtclib = "0.7.0"
-reqwest = { version = "0.11.5", features = ["json", "blocking", "multipart"] }
+anyhow = "1.0.56"
+evtclib = "0.7.1"
+reqwest = { version = "0.11.10", features = ["json", "blocking", "multipart"] }
url = { version = "2.2.2", features = ["serde"] }
-serde = { version = "1.0.111", features = ["derive"] }
-chrono = "0.4.11"
-notify = "4.0.15"
-regex = "1.3.9"
-zip = "0.5.5"
-toml = "0.5.6"
-itertools = "0.10.0"
+serde = { version = "1.0.136", features = ["derive"] }
+chrono = "0.4.19"
+notify = "4.0.17"
+regex = "1.5.5"
+zip = "0.6.1"
+toml = "0.5.8"
+itertools = "0.10.3"
# Optional features for IM integration
-tokio = { version = "1.12", features = ["rt"], optional = true }
+tokio = { version = "1.17.0", features = ["rt"], optional = true }
matrix-sdk = { version = "0.4.1", optional = true }
-ruma = { version = "0.4", optional = true, features = ["api", "client", "events"] }
[dependencies.serenity]
default-features = false
@@ -43,9 +42,9 @@ features = [
"utils",
"rustls_backend",
]
-version = "0.10"
+version = "0.10.10"
optional = true
[dependencies.serde_with]
-version = "1.11.0"
+version = "1.12.0"
features = []