diff options
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 12 |
1 files changed, 9 insertions, 3 deletions
@@ -7,6 +7,10 @@ license = "MIT" # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html +[features] +im-matrix = ["matrix-sdk", "tokio"] +im-discord = ["serenity", "tokio"] + [dependencies] clap = "3.0.0-beta.1" log = "0.4.8" @@ -14,15 +18,16 @@ pretty_env_logger = "0.4.0" anyhow = "1.0.31" evtclib = "0.5.0" reqwest = { version = "0.10.6", features = ["json", "blocking"] } -serde = "1.0.111" +serde = { version = "1.0.111", features = ["derive"] } chrono = "0.4.11" notify = "4.0.15" regex = "1.3.9" zip = "0.5.5" toml = "0.5.6" -tokio = { version = "0.2", features = ["rt-core"] } -matrix-sdk = "0.2.0" itertools = "0.10.0" +# Optional features for IM integration +tokio = { version = "0.2", features = ["rt-core"], optional = true } +matrix-sdk = { version = "0.2.0", optional = true } [dependencies.serenity] default-features = false @@ -37,3 +42,4 @@ features = [ "rustls_backend", ] version = "0.9" +optional = true |