aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Schadt <kingdread@gmx.de>2020-04-04 13:48:56 +0200
committerDaniel Schadt <kingdread@gmx.de>2020-04-04 13:55:20 +0200
commit4ec62bbac872bbfd95413af2f00c3f4a36c70630 (patch)
tree22cac1ff6f9776565d9f35322c463ec6125c0bc7 /Cargo.toml
parent22738da2cd36b4ae2e1fb5efd23373e6b77405a2 (diff)
downloadevtclib-4ec62bbac872bbfd95413af2f00c3f4a36c70630.tar.gz
evtclib-4ec62bbac872bbfd95413af2f00c3f4a36c70630.tar.bz2
evtclib-4ec62bbac872bbfd95413af2f00c3f4a36c70630.zip
switch from quick_error to thiserror
thiserror seems to be the more modern approach that also works with the new Error trait from std.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f4697a2..b6c1c90 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,7 +7,7 @@ edition = "2018"
[dependencies]
num-traits = "0.2"
num-derive = "0.3"
-quick-error = "1.2.1"
+thiserror = "1.0"
byteorder = "1"
fnv = "1.0.3"
getset = "0.1"