summaryrefslogtreecommitdiff
path: root/candy-kingdom-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'candy-kingdom-git/PKGBUILD')
-rw-r--r--candy-kingdom-git/PKGBUILD38
1 files changed, 0 insertions, 38 deletions
diff --git a/candy-kingdom-git/PKGBUILD b/candy-kingdom-git/PKGBUILD
deleted file mode 100644
index 0952ffb..0000000
--- a/candy-kingdom-git/PKGBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-pkgname=candy-kingdom-git
-_pkgname=candy-kingdom
-pkgver=1388
-pkgrel=1
-pkgdesc="A collection of SAT solvers and tools for structure analysis in SAT problems."
-arch=("any")
-url="https://github.com/Udopia/candy-kingdom"
-license=("MIT")
-makedepends=("cmake" "git")
-source=(
- "${_pkgname}::git+https://github.com/Udopia/candy-kingdom.git#branch=master"
-)
-sha256sums=('SKIP')
-
-pkgver() {
- cd "${_pkgname}"
- git rev-list --count HEAD
-}
-
-prepare() {
- cd "${_pkgname}"
- git submodule init
- git submodule set-url -- lib/oscpack https://github.com/Udopia/oscpack.git
- git submodule update
-}
-
-build() {
- mkdir -p "${_pkgname}/build"
- cd "${_pkgname}/build"
- cmake -DCMAKE_BUILD_TYPE=Release ..
- make candy
-}
-
-package() {
- cd "${_pkgname}/build"
- install -Dm 755 candy "${pkgdir}/usr/bin/candy"
- install -Dm 644 libcandylib.a "${pkgdir}/usr/lib/libcandylib.a"
-}